Canadian Dollar (CAD) Withdrawal Issues
Incident Report for Coinsquare
Resolved
The issue we were experiencing with Canadian Dollar (CAD) withdrawals is now resolved.
Posted Sep 19, 2022 - 12:18 EDT
Investigating
We are currently experiencing an issue with Canadian Dollar (CAD) withdrawals. Our team is working on a solution. Rest assured that your funds are safe. Our sincere apologies for the inconvenience.
Posted Sep 19, 2022 - 09:18 EDT
This incident affected: CAD Withdrawals.