US Dollar (USD) Incorrect Prices
Incident Report for Coinsquare
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 11:31 EST
Identified
We are aware of an issue impacting our US Dollar (USD) price chart. Please note, USD prices may not accurately reflect markets. Our team is aware and actively working to resolve the issue. Our apologies for the inconvenience.
Posted Nov 13, 2022 - 09:44 EST
This incident affected: iOS/Android Apps and Trading.