All Systems Operational
CAD Funding Operational
CAD Withdrawals Operational
iOS/Android Apps Operational
Trading Operational
Digital Currency Deposits Operational
90 days ago
99.99 % uptime
Today
Digital Currency Withdrawals Operational
90 days ago
99.99 % uptime
Today
Staking Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Apr 26, 2024

No incidents reported today.

Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024
Completed - The scheduled maintenance has been completed.
Apr 20, 07:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 20, 06:00 EDT
Scheduled - Coinsquare will be undergoing scheduled dealer maintenance on Saturday, April 20, 2024 for 1 hour beginning at 6:00 am ET.

During the maintenance period, our platform will be temporarily unavailable and users will be unable to log in or make deposits, trades or withdrawals.

You will be able to access the platform and its services at 7:00 am ET. However, Pro Trade will only allow you to cancel orders from 7:00 am ET until the marketplace reopens at 7:30 am ET. After the marketplace reopens, you will be permitted to place new orders.

We apologize for any inconvenience this may cause and thank you for your understanding.

Apr 12, 17:12 EDT
Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.