Digital Currency Withdrawals
Incident Report for Coinsquare
Resolved
The incident has been resolved!
Posted Nov 13, 2022 - 13:34 EST
Identified
Users are currently unable to withdraw digital currency. Our team is actively working to resolve the issue and we expect to have a resolution shortly. Rest assured all assets are safe and our apologies for the inconvenience.
Posted Nov 13, 2022 - 10:23 EST
This incident affected: Digital Currency Withdrawals.