Service Disruption
Incident Report for Coinsquare
Monitoring
Great news! Full service has been restored on web and mobile, including fiat and crypto deposits/withdrawals. We thank you for your patience throughout the day and continued support. Please note that we are aware that prior transaction history is not visible in the application and that our engineers have identified a fix. We hope to have this restored shortly and will update our status page when complete. Status.coinsquare.com.
Posted Nov 25, 2022 - 20:17 EST
Update
Mobile apps service has now been restored. Our team is working to restore the web platform. We expect to provide another update shortly.
Posted Nov 25, 2022 - 17:45 EST
Update
Our tech team has encountered some challenges during our maintenance window and are working closely with our vendors to restore functionality. Rest assured all funds are safe and we expect to have the issue resolved shortly.
Posted Nov 25, 2022 - 08:48 EST
Update
Our team has been able to resolve the system-wide email disruption. Please note, the team is now working to restore past transaction history. Thank you for your patience.
Posted Nov 23, 2022 - 06:58 EST
Investigating
Please note, we are currently working to restore past transaction history. In addition, our team is aware of a system-wide email disruption. If you have not received an expected email, we kindly ask you reattempt the request in a few hours. Our tech team is actively investigating and hopes to have a fix our shortly.
Posted Nov 22, 2022 - 23:23 EST
This incident affects: CAD Withdrawals.