Issues with Pro Order Book

Incident Report for Coinsquare

Resolved

This issue has been resolved. We are currently in cancel-only mode, meaning you will only be able to cancel existing trade orders from 4:10 pm EDT until the marketplace reopens at 4:40 pm EDT. After the marketplace reopens, you will be permitted to place new orders.
Posted May 07, 2026 - 16:08 EDT

Investigating

We are currently investigating an issue with the Pro Trade order book.
Posted May 07, 2026 - 08:35 EDT
This incident affected: Trading (Pro Trade & Limit Orders).