The network migration has been completed ahead of schedule. Deposits, withdrawals, and all staking activities for Polkadot (DOT) have now been fully restored.
Posted Nov 05, 2025 - 11:44 EST
In progress
The Polkadot (DOT) network migration is currently in progress. We will provide updates as necessary.
Posted Nov 03, 2025 - 16:00 EST
Scheduled
In light of Polkadot's upcoming network migration scheduled for November 4, 2025, all deposits, withdrawals, and staking activities for Polkadot (DOT) will be temporarily paused on November 3, 2025.
Please note that this migration process will not impact trading activities or staking rewards.
We expect to resume all DOT-related activities by November 6, 2025. Thank you for your understanding as we work through this migration.
Posted Nov 03, 2025 - 09:42 EST
This scheduled maintenance affected: Digital Currency Deposits, Digital Currency Withdrawals and Staking (Polkadot (DOT)).