Issues cancelling Pro Trade orders

Incident Report for Coinsquare

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 13:40 EDT

Investigating

We are currently investigating an issue where some Pro Trade orders cannot be cancelled.
Please contact our Support team if you are experiencing this issue: https://support.coinsquare.com/hc/en-us/requests/new
Posted May 28, 2026 - 15:17 EDT
This incident affected: Trading (Pro Trade & Limit Orders).