Platform issues

Incident Report for Coinsquare

Resolved

This problem has been resolved. Thank you for your patience and understanding!
Posted May 05, 2026 - 16:14 EDT

Monitoring

Services are recovering and we are monitoring the results.
Posted May 05, 2026 - 16:07 EDT

Investigating

We are currently investigating an issue with the platform. Please rest assured your funds are safe and we are working to resolve this as quickly as possible.
Posted May 05, 2026 - 15:44 EDT
This incident affected: Trading (Quick Trade, Pro Trade & Limit Orders), Staking (Solana (SOL), Polygon (MATIC), Cardano (ADA), Polkadot (DOT), Near (NEAR), Cosmos (ATOM), Ethereum (ETH), Celestia (TIA), Injective (INJ)), and CAD Withdrawals, iOS/Android Apps, Digital Currency Deposits, Digital Currency Withdrawals.