August 17 - Crypto Withdrawal Delay
Incident Report for Coinsquare
Resolved
The issue with digital currency withdrawals has been resolved and full service has been restored. We appreciate your patience! For any outstanding concerns, please reach out to Support: support@coinsquare.com
Posted Aug 18, 2022 - 10:06 EDT
Investigating
We are currently experiencing an issue with digital currency withdrawals, specifically BTC withdrawals. Clients may experience longer than normal delays when making withdrawal requests during this time. Rest assured that all funds are safe and all transactions will reach their intended destination. Our apologies for the inconvenience.
Posted Aug 17, 2022 - 14:28 EDT
This incident affected: Digital Currency Withdrawals.