E-Transfer Withdrawal Issues

Incident Report for Coinsquare

Resolved

This issue should now be resolved.
Posted Sep 03, 2025 - 11:51 EDT

Investigating

We are currently investigating an issue with our funding partner affecting E-Transfer withdrawals. Direct bank deposit and wire transfers are unaffected.
Posted Sep 03, 2025 - 11:21 EDT
This incident affected: CAD Withdrawals.